Timeboxing broken in Desktop app

Incident Report for Sunsama

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 16:03 UTC

Investigating

We're seeing a problem with the desktop app version 3.3.5 where time boxing isn't working.
Posted Mar 24, 2026 - 14:30 UTC
This incident affected: Apps (Web, Desktop, Mobile).