Customize trial not working
Incident Report for Sunsama
Resolved
This incident has been resolved.
Posted Jul 08, 2021 - 14:46 UTC
Update
The "Onward" button is now working, sorry for the trouble!
Posted Jul 08, 2021 - 14:46 UTC
Investigating
We are aware the "Onward" button from the "Customize trial" page isn't working right now. We're investigating.
Posted Jul 08, 2021 - 14:39 UTC
This incident affected: Website.