Missing tasks
Incident Report for Sunsama
Resolved
We've finally restored visibility for all of the 2M tasks affected, and systems are looking normal again. Thank you so much for your patience, and no data should've been lost!
Posted Apr 19, 2021 - 13:10 UTC
Update
We have confidently fixed the cause of problem and confirm it is fixed. Right now we're working on restoring all data visibility with minimal customer action required.
Posted Apr 19, 2021 - 11:15 UTC
Update
While testing we noticed the fix was incomplete and are working on restoring the data visibility, while verifying the new fix.
Posted Apr 19, 2021 - 10:42 UTC
Identified
We've identified what seems to be the culprit, an update from Friday which would be hiding expired recurring tasks. We'll revert it for now and will investigate the problematic logic in that update. We'll also revert all tasks that were erroneously hidden, which can bring back a few deleted tasks that were intentionally deleted.
Posted Apr 19, 2021 - 09:45 UTC
Investigating
We're seeing many reports of missing tasks from customers but are unable to find a cause yet. We're currently investigating and will try to publish an update in 30 minutes or less.
Posted Apr 19, 2021 - 09:12 UTC
This incident affected: Apps (Web, Desktop, Mobile).